Results 1 to 4 of 4

Thread: Strange problem with libcod and meat bot

  1. #1
    Private
    Join Date
    Apr 2020
    Posts
    44
    Thanks
    18
    Thanked 10 Times in 9 Posts

    Strange problem with libcod and meat bot

    Hi
    I need your help about my problem.
    The last days i have been messing around with meatbot on my local windows machine with no big problems. I even tried libcod for windows and it worked fine. The problem is that when i tried to upload meatbot to my linux server (that uses libcod) it stopped functioning properly. Specifically the bots will move until they meet enemy bot but then they freeze. If i join the game and shoot those bots then my bot allies will move until they find the next enemy bot and then freeze again. They don't shoot any bullets. My first thought was that i had messed up the code at some point so i tried unmodified versions of meatbot (both 0.92 and 0.93) but the problem was still there. Next i tried different different versions of libcod and the problem remained. The next thing i tried is to run the server without libcod and then the bots worked like on my local pc. What could be the issue? Any help welcome.

  2. The Following User Says Thank You to agribilos For This Useful Post:

    kung foo man (19th January 2021)

  3. #2
    Assadministrator IzNoGoD's Avatar
    Join Date
    Aug 2012
    Posts
    1,652
    Thanks
    17
    Thanked 993 Times in 623 Posts
    Try config.hpp setting COMPILE_BOTS to 0 and recompiling libcod.

    There's a hook for bot movement that gets compiled in by default, it might be messing with meatbot stuffs.
    "Does not work" is an error report for a bug between keyboard and chair.

    All hail Artie Effem

    Sending me a private message makes me want to help you LESS.

  4. The Following 3 Users Say Thank You to IzNoGoD For This Useful Post:

    agribilos (19th January 2021),kung foo man (20th January 2021),Mitch (21st January 2021)

  5. #3
    Private
    Join Date
    Apr 2020
    Posts
    44
    Thanks
    18
    Thanked 10 Times in 9 Posts
    ok i will try that. Thanks

  6. #4
    Private
    Join Date
    Apr 2020
    Posts
    44
    Thanks
    18
    Thanked 10 Times in 9 Posts
    Ok it seems to have resolved the issue. Thanks again

  7. The Following 2 Users Say Thank You to agribilos For This Useful Post:

    kung foo man (20th January 2021),Mitch (21st January 2021)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •