Results 1 to 6 of 6

Thread: Apache tells about not existing folder

  1. #1
    Private First Class Earliboy's Avatar
    Join Date
    Nov 2012
    Location
    Germany
    Posts
    130
    Thanks
    5
    Thanked 88 Times in 61 Posts

    Apache tells about not existing folder

    Hello,
    I installed Xampp with apache2 + mysql on Windows 7 ultimate 64 Bit.
    Now i added in the Vhost file:
    Code:
    <VirtualHost test.localhost:80>
    	DocumentRoot S:/website/work
    	#DocumentRoot C:/xampp/htdocs/
    	ServerName test.localhost:80
    	ServerAdmin admin@localhost
    	ErrorLog "logs/test.localhost-error.log"
    	CustomLog "logs/test.localhost.log" common
    	#<Directory "C:/xampp/htdocs/work">
    	<Directory S:/website/work>
    		Options Indexes FollowSymLinks
    		AllowOverride FileInfo
    		Order allow,deny
    		Allow from all
    	</Directory>
    </VirtualHost>
    The problem is:
    AH00112: Warning: DocumentRoot [S:/website/work] does not exist, but it does! I just copied that line.
    Even if i add a link in the localhost folder, it doesnt redirects me too.
    If i change the directory in the vhost config to C:/campp/htdocs/, it works perfect. I get same access like localhost.
    I allready added the test.localhost to the windows host file, before i couldnt even access test.localhost.

    I hope anyone knows whats wrong with it, normaly i should get access to it.

    Greetings
    Earliboy
    No ... No ... this is not possible .......

  2. #2
    Assadministrator kung foo man's Avatar
    Join Date
    Jun 2012
    Location
    trailerpark
    Posts
    1,962
    Thanks
    1,894
    Thanked 1,062 Times in 738 Posts
    Maybe permission issue?
    timescale 0.01

  3. #3
    Brigadier General
    Join Date
    Dec 2012
    Posts
    1,003
    Thanks
    439
    Thanked 166 Times in 128 Posts
    I dont know anything about it, but check this
    http://slaptijack.com/system-adminis...oes-not-exist/

  4. #4
    Private First Class Earliboy's Avatar
    Join Date
    Nov 2012
    Location
    Germany
    Posts
    130
    Thanks
    5
    Thanked 88 Times in 61 Posts
    Quote Originally Posted by Earliboy View Post
    Hello,
    I installed Xampp with apache2 + mysql on Windows 7 ultimate 64 Bit.
    So, im not using windows.
    And yes, i checked and it should work perfect. I also checked by setting the permission of a folder to only the system itself. Then apache tells about permissions, so its not a permissions prob.
    No ... No ... this is not possible .......

  5. #5
    Brigadier General
    Join Date
    Dec 2012
    Posts
    1,003
    Thanks
    439
    Thanked 166 Times in 128 Posts
    My bad
    "You could use the following command utility called junction from Mark Russinovich Sysinternals - www.sysinternals.com

    junction c:\my_symlink "U:\networkpath\dir"

    you could now set your DocumentRoot directive in as C:\my_symlink

    restart Apache and that should work.

    This however requires that you set have mapped the network drive correctly using net use command (perhaps with the peristence option)"

    "i have found a solution, if i run apache from command line, it worked. but not from service."

  6. #6
    Private First Class Earliboy's Avatar
    Join Date
    Nov 2012
    Location
    Germany
    Posts
    130
    Thanks
    5
    Thanked 88 Times in 61 Posts
    My fault, i copied that stuff with Dir from a forum, to be sure i set it right.
    <Directory “S:/website/work”> the "" are different > syntax error.
    thx to kung, he found it.
    Last edited by Earliboy; 20th March 2013 at 15:00.
    No ... No ... this is not possible .......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •