Results 1 to 7 of 7

Thread: Punkbuster issue in CoD2

  1. #1
    Private
    Join Date
    Mar 2018
    Posts
    36
    Thanks
    8
    Thanked 5 Times in 5 Posts

    Punkbuster issue in CoD2

    Hello.

    I have a problem with punkbuster.
    Well I've created a CoD 2 CRACKED server with latest PB files (downloaded from, cybergames), and I have a problem with guid - everyone who conneted to server is automatically kicked for the same guid (guid 0).
    So what I must do, to surpass this issue with guid 0,cracked cod2 linux starting files and pb on?
    Last edited by rgl12; 10th September 2018 at 07:34.

  2. The Following User Says Thank You to rgl12 For This Useful Post:

    kung foo man (10th September 2018)

  3. #2
    Private Polat's Avatar
    Join Date
    Jan 2018
    Location
    Israel
    Posts
    25
    Thanks
    9
    Thanked 18 Times in 14 Posts
    Hello there,

    It's easy to solve just write this command when you turn on your server

    Code:
    /rcon pb_sv_guidrelax 7
    Code:
    sudo apt-get install betterbrainforscirpting

  4. The Following User Says Thank You to Polat For This Useful Post:

    kung foo man (10th September 2018)

  5. #3
    Private
    Join Date
    Mar 2018
    Posts
    36
    Thanks
    8
    Thanked 5 Times in 5 Posts
    Well I must be doing something wrong.

    Thats my starting command:

    Code:
    ./cod2_lnxded_1_3_nodelay_va_loc + set fs_game pam + set sv_pam "1" + set pam_mode "cg" +set sv_punkbuster "1" + set dedicated "2" + +set net_port "28962" + set scr_teambalance "1" +exec pam.cfg + map_rotate
    Here are mine general settings of pbsv.cfg:
    Code:
    ; General Settings
    ; ------------------------------
    pb_sv_MsgPrefix "^3PunkBuster Server"
    pb_sv_MaxDlRate 4 //[KB/sec requested per file (default=4)]
    pb_sv_MaxConDls 6 //[Concurrent downloads (default=1)]
    pb_sv_MaxSendRate 8 // [speed at which PB Server sends pbcl and pbag updates in KBps (default=8)] 
    pb_sv_CQC 1 //[0=No, 1=Yes (default=1)]
    pb_sv_Sleep 60 //[# of Milliseconds (default=60)]
    pb_sv_PowerMin 10 //[Power Points]
    pb_sv_PowerDef 1 //[Power Points]
    pb_sv_PowerKickLen 5 //[Minutes (default=5)]
    pb_sv_DupNameGrace 0 //[Seconds]
    pb_sv_ExtChar 0 //[0=No, 1=Yes (default=0)]
    pb_sv_GuidRelax 7 //[1=UNKN, 2=WRONGIP, 4=DUP (add desired values)]
    pb_sv_RconReload 0 //[0=No, 1=Yes (default=0)]
    pb_sv_LogSync 0 //[0=No, 1=Yes (default=0)]/
    pb_sv_AutoUpdBan 1 //[0=No, 1=Yes (default=0)][

    and it still kicks me, or my friends when, second person is trying to connect. :/

    I've also tried:
    Code:
     /rcon login "password"
    /rcon pb_sv_guidrelax 7
    /rcon pb_sv_restart
    still without any success. :/

  6. The Following User Says Thank You to rgl12 For This Useful Post:

    kung foo man (10th September 2018)

  7. #4
    Private Polat's Avatar
    Join Date
    Jan 2018
    Location
    Israel
    Posts
    25
    Thanks
    9
    Thanked 18 Times in 14 Posts
    Well, I think the problem with the Linux files.

    Could you please try to re-install the PB for Linux from HERE ?

    And do the commands again... pb_sv_guidrelax 7

    -----------------------------------------------------------------------------------

    [Edit]

    As I see, you didn't exec your pbsv.cfg in your startup line, make sure that you put +exec pbsv.cfg in startup line or in your server.cfg
    If you did that already, then try to reinstall the PB from the link I sent.
    Last edited by Polat; 10th September 2018 at 15:29.
    Code:
    sudo apt-get install betterbrainforscirpting

  8. The Following User Says Thank You to Polat For This Useful Post:

    kung foo man (10th September 2018)

  9. #5
    Private
    Join Date
    Mar 2018
    Posts
    36
    Thanks
    8
    Thanked 5 Times in 5 Posts
    Still something is not right, and i really dont know what.

    Now I've tried to run server with this command:

    Code:
    ./cod2_lnxded_1_3_nodelay_va_loc + set fs_game pam + set sv_pam "1" + set pam_mode "cg" +set sv_punkbuster "1" +fs_path pb + exec pbsv.cfg + set dedicated "2" + +set net_port "28962" + set scr_teambalance "1" +exec pam.cfg + map_rotate
    and it still doesnt work.

    PB files, are from https://community.pbbans.com/files/f...-duty-2-linux/ so I think those are the latest one.

    Any solutions?

  10. #6
    Private Polat's Avatar
    Join Date
    Jan 2018
    Location
    Israel
    Posts
    25
    Thanks
    9
    Thanked 18 Times in 14 Posts
    Yes, you're writing startup line in the wrong way, here is the correct one...

    Code:
    ./cod2_lnxded_1_3_nodelay_va_loc +set fs_game pam +set sv_pam "1" +set pam_mode "cg" +set sv_punkbuster "1" +fs_path pb +exec pbsv.cfg +set dedicated "2" +set net_port "28962" +set scr_teambalance "1" +exec pam.cfg +map_rotate

    The problem in the startup line is that you're adding space after "+"
    Code:
    sudo apt-get install betterbrainforscirpting

  11. #7
    Private
    Join Date
    Mar 2018
    Posts
    36
    Thanks
    8
    Thanked 5 Times in 5 Posts
    Thank You, for Your time Polat.
    I'll try this command, when I'll be back home this afternoon.

  12. The Following User Says Thank You to rgl12 For This Useful Post:

    kubislav23 (11th September 2018)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •