Cod2 Weapon Import Tutorial
In this tutorial I’m going to explain how you can import a custom weapon into Cod2. (Most of the steps work in other Cods too) I assume you’ve already made the 3d model of your weapon and textured it with a UVmap. This texture should be a power of 2. There’s already a tutorial about this (made by Sevensniff), but I think it’s not clear enough and certain files are missing. 
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[bookmark: _Toc305270550]Requirements
Let’s start off with the requirements.
Requirements:
· Maya 6.0 (Personal Learning edition doesn’t work)
· Modtools http://callofduty.filefront.com/file/CoD2_Updated_MapMod_Tools;61008
· Viewsleeves files http://www.gamefront.com/files/20848347/viewsleeves.rar 
· (xmodelexportwindow fix) http://www.gamefront.com/files/20848348/CODExportModelWindow.rar 

The xmodelexportwindow is a replacement file for the original exportwindow. Certain versions won’t export a model properly, so this is where the xmodelexportwindow comes in handy. 
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Setting up the Maya plugins is pretty easy. Let’s start with browsing to your Maya folder. The standard pathway would be: C:\Documents and Settings\[user]\My Documents\maya\6.0
Check if there’s already a file in this folder called maya.env . If so open it and type the text displayed in the box below if not start up notepad or a similar program and then type the text displayed in the box below.
	MAYA_SCRIPT_PATH = C:\Program Files\Activision\Call of Duty 2\bin\maya
MAYA_PLUG_IN_PATH = C:\Program Files\Activision\Call of Duty 2\bin\maya



Change the path where needed to make it fit to your configurations. Save this file in the maya 6.0 folder under the name Maya.env. Put the ‘Save as type’ on ‘All Files’and simply press save. 

Now you’ve done that, let’s create/open the Usersetup.mel. Same procedure as above. If it’s there you just open it, if not you create it (it’s located in ...\maya 6.0\scripts). Type the following in the Usersetup.mel. 
	source CODToolsMenu;
CODStartup;
CODToolsMenu;



You don’t have to change anything this time and you can just save it in (...\maya 6.0\scripts). Save as, Usersetup.mel. Again, put the ‘Save as type’ on ‘All Files’ and simply press save.
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So you’re done with the maya plugins and you’re almost good to go. But there are a few rules and other things you should know/do. First off:
· You never change the following files:
· The standard TGA files that come along with the viewsleeves files
· Viewmodel_defmesh
· Viewmodel_rig
· The ammoclip of your weapon should be separated from the rest. It’s mesh may not be attached to any other mesh that isn’t part of the ammoclip. The reason for this: Later on in this tutorial you’re gonna have to attach a joint to that mesh. If it’s connected to e.g. the mainpart of the gun, the gun’s mesh will get stretched out if you move the clip.
· Rig=skeleton
· ADS= Aim down sight
· When animating we use constraints, not the joints.
· In the tutorial I’ll be talking about e.g. filenames with the name ‘weapon’. Replace weapon with the name of your weapon.
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1. If you take a look at the viewsleeves files you’ll see the follow files.
	american_thread_color.TGA // Leave it be. 

	hand_us_c.TGA // Leave it be.

	weapon_thompson_c.TGA // Leave it be. It’s better not to mesh with the .tgas. 

	viewmodel_defmesh // Don’t you dare touching it.

	viewmodel_rig // Same as above.

	thompson_VMGun

	viewmodel_thompson_gunsleeves.ma

	viewmodelanimation_thompson.ma

	viewmodelanimation_usethisforyouranim.ma



These files are essential to importing a weapon into cod2. So make a backup of these files and start changing all the filenames by replacing Thompson with the name of your gun. Now go to your backup and copy the Thompson.VMgun file to the folder filled with the files you’re using. This means you should have two files with the VMgun extension.
[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\1.bmp]


2. Open 'weapon'.VMGun. It’s actually a Maya file with a changed extension, so you shouldn’t have any problems opening it. After you’ve opened the .VMgun you import your own weapon by pressing File > Import in the upper left corner. Now correct the position of your weapon by scaling, rotating and moving it, until it matches the position of the Thompson. 




[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\2.bmp]3. In the upper left corner there’s a dropdown menu. It’s probably on Modeling but you have to put it on Animation. Now go to Window>Hypergraph and select the Thompson’s meshes. Press Skin>Detach Skin as displayed by the image below. After detaching the meshes you delete them.





4. Adjust the joints, J_clip, tag_brass, tag_flash and tag_bolt so they match your gun. Don’t move the J_gun, it’s the parent joint and it will move the whole rig. A short explanation about the joints:
· J_clip = The position of the ammoclip
· tag_brass= The spot empty bulletcases will pop out when firing.
· tag_flash= The position of  the fx of your gun.
· tag_bolt= The position of the bolt.
· J_Gun= It´s the parent joint. Every other joint is connected to it.
[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\3.bmp]




5A. When you’re done positioning all the joints, all you have to do is bind them to the right meshes. Select the joint and the right mesh and press Skin>Bind Skin> Smooth bind.
· J_clip>Ammoclip (If you don’t have a clip, just leave the joint and don’t use it at all
· 
J_Gun>Mainpart of your weapon
· [image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\4.bmp]J_bolt>Bolt (If you don’t have a bolt, don’t worry. Just leave the joint and don’t use it at all.








[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\5.bmp]5B. Go to Cod Tools > Model Export and create a new entry if there’s none already. Check Force Export Selected Joints. |
You could enter a systempath+name, but most of the time only the name does the trick and it appears in the folder the .VMgun is in. But to be really sure just enter a systempath. Let’s try to keep things clear and obvious, so you won’t mistake files for each other. So enter the name like this: Viewmodel_’weapon’. This will be the file you’ll see in 1st person and in cod it’s referred to as viewmodel. 
So after you’ve entered all that info, you should select all your meshes and put them into one group if they weren’t already. You can group them easily by pressing Window>Hypergraph selecting all the meshes and press ‘Ctrl+G’. If done correctly, a block named group(Parent) will appear with the selected amount of meshes beneath it(Children).
Select the whole rig and only the block named group(Parent) in hypergraph and press ‘Set exports’ in the Model Export window. If you’ve still got them selected press ‘Export all entries’. You’ll see a process bar appear. If everything goes right it simply hits 100% and disappears. If not you’ll see an error appear in the downright corner in the Maya Console.


Congratulations, you’re now done with the VMgun file! Save the scene and open the viewmodel_’weapon’_gunsleeves.ma file.

6. Delete the Thompson meshes and select the J_Gun joint. Press Skeleton>Disconnect Joint. Now you can delete the thompson’s rig, a joint will appear and it’s called joint2. Simply delete it and press File>Import and select ‘weapon’.VMgun. Now detach the meshes of your weapon by pressing Skin>detach. Open Window>Hypergraph and zoom out until you can see J_Gun(on the right)  and tag_weapon(located on the end of the big list on the left). Now drag J_Gun onto tag_weapon by using the middle mouse button. 
[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\6.bmp]

[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\7.bmp]

[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\JOINTsign.bmp]7. Open Codtools>Modelexporter and create a new entry, if one isn’t created already, and check Force Export Selected Joints. Now press Window>Hypergraph and select EVERY joint. (Every block that has a joint sign) 


You must also select the PARENTGROUP of group2 and group3. Select the meshes of group 3 too (Lefthand,Righthand) and click on SET exports. Now insert a (systempath+) name. The name should be something like xanim_viewmodel_’weapon’. It’s a reference rig for in asset manager. Now click ‘Export all Entries’ 
Hint: I’m not sure but there should be a standard entry. You could click on Select Exports and open Window>Hypergraph and select your weapon’s meshes’ parentgroup too. Then click set exports.. This saves you a lot of work :) 

Save the scene and open up Viewmodelanimation_usethisforyouranim.ma. 
[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\9.bmp]


8. You could use viewmodelanimation_’weapon’ too, but all the animations are already set. So it’s hard to edit them. You could also use it as an example. I advise you to use the usethisforyouranim file.  The ADS up, ADS down and IDLE are already done, but easy editable. 

9. Go to File>Reference editor and click on VM_GunRN thompson.VMGUN. In the textbox ‘Unresolved Name’ you must insert the systempath+’weapon’.VMgun. The Thompson should now be replaced by your weapon.
[image: import_weapons_tut_10.png]

10. I’m not going to cover the whole animation part. I’m just going to tell you some basics. 
· Everything you want to move is done by moving Constraints, press Show>Nurbs Curves and handles in every viewpanel to make them visible. You don’t animate by using the joints, except for two anims. 



· Weapon + Hands movement (Rotation and translation): Gun_CTR<You can’t move the weapon separately from the hands
· Separate hand movement (Rotation and translation): Hand_Gun_CTR_LE and Hand_Gun_CTR_RI
· Elbow movement(translation):PoleV_LE and PoleV_RI
· Shoulder movement (translation): Shoulder_LE_CTR and Shoulder_RI_CTR
· Finger movement(Rotation): The black handles (the crosses)
· Weaponparts (Rotation and translation): Clip>J_Clip – Bolt>J_bolt.
· [image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\14.bmp]ADS: Torso_CTR<For ADS ONLY! 



· If you want something like the gun to move upwards and the hands downwards, you should animate Gun_CTR first and go an amount of X frames back to animate the hands.

· When your done moving something in a frame, you must select the constraint(s) you’ve used and press S (setkey). The translation & rotation will be saved for that frame. Things you change but didn’t select when you pressed S won’t be saved.
[image: import_weapons_tut_13.png]

· If you don’t want to animate frame after frame, you could do the following: Let’s say the translation of HAND_GUN_CTR_RI is TranslationX=5 at frame 50 and you want the hand to move to TranslationX=10 at frame 70.  You select HAND_GUN_CTR_RI at frame 50 and press S. Now  you’ve got to go to frame 70 and move HAND_GUN_CTR_RI to TranslationX=10. Now press S and play. You’ll see that the hand will move very smoothly from TranslationX=5 to TranslationX=10 in 20 frames. This saves ALOT of frame-after-frame-work. 

· If you want to play e.g. frame 50-70 only, you have to configure the framemenu below.
 [0.00][50]-------------------------------------[70][400.00]
[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\12.bmp]






· The following animation are needed to make a standard weapon like a Thompson.

· viewmodel_'weapon'_ads_down // Zoom out -- tag_view, tag_torso
· viewmodel_'weapon'_ads_up // Zoom in -- tag_view, tag_torso 
· viewmodel_'weapon'_idle // Idle position -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_fire // Fire -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_lastshot // Last  bullet in clip -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_reload_not_empty // Reload when the clip isn’t empty yet -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_reload // Reload when the clip is totally empty. -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_putaway // Put the weapon away -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_putaway_fast // Put the weapon away fast  -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_pullout // Pull out the weapon -- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_pullout_fast // Pull out the weapon fast-- Whole (weapon)rig except for tag_view and tag_torso
· viewmodel_'weapon'_melee // Bash attack – Whole (weapon)rig except for tag_view and tag_torso
It doesn’t matter when an animation begins or ends, you can insert start+ending in the entry in the Anim exporter. Just make sure you don’t let certain animations take too long or be to short.

11. You can use viewmodelanimation_thompson as an example! You can lookup animation durations and the way they animated it.
12. When you’re done animating and you’re satisfied with what you’ve got, you open Window > Hypergraph and Codtools>Animation Export. Create an entry for every animation you’ve got and insert (systempath+) name (as displayed above). Also select the specified things above and click set export. Do this for every entry! Now insert every start and end frame of the animations. Idle only takes 1 frame, e.g.[50] [50]. Click on Export all entries.

[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\16.bmp]


Hint: I’m not sure but there should be a standard entry called viewmodel_thompson_idle. You could click on Select Exports and open Window>Hypergraph and select your weapon’s rig too and then press set exports at every entry except for ADS up/Down. This saves you a lot of work :) 







13A. Move all your xanim files to (...\Call of Duty 2\xanim_export) and all your xmodel files to (...\Call of Duty 2\xmodel_export).

13B. Go to (...\Call of Duty 2\source_data) and open the file modelmatch.csv. Delete all the text and replace it with:
	base_character\base_character.XMODEL_EXPORT


 
14. Open Asset Manager and create a Material Entry and give it the texture of your weapon’s name.
Configs:
MaterialType: Model Phong
SurfaceType: Metal/of iets anders waar je weapon van is gemaakt.
Colormap: Press[…] and load your weapon’s texture. 
Check NOPICMIP at Colormap 

[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\17.bmp]

15. Create another entry but a xmodel one this time. Name it viewmodel_’weapon’. At ‘Filename’ you must click on the […] button to load you viewmodel_’weapon’ file.
Configs:
Type: Viewmodel
Leave the rest.

[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\18.bmp]

16. Create a xanim entry for each animation you’ve got. Name: Viewmodel_’weapon’_’actoion’. 
Configs: 
Filename > pick your action 
model > Pick the xanim_viewmodel_’weapon’ file 
looping [ ] NO
useBones [ ]NO
type: Relative
Leave the rest.


[image: C:\Documents and Settings\Administrator\Bureaublad\Ongebruikte bureaubladpictogrammen\Weapon import\19.bmp]

---Repeat step16 for each animation you’ve got. After that you can convert every entry. Start with the materials, xmodel and then the anims.
17. You can find all the converted files in your Main folder under the folders xmodel, xmodelparts,xmodelsurfs,xanim,material and images. Put these all in your IWD archive. 
The IWD structure:
-images  
-materials 
-xanim 
-xmodel 
-xmodelparts // -xmodelsurfs 
-weapons>mp // put your ‘weapon’ file in here.
-ui_mp>scriptmenus//put the weapon_american/british/russian/german.menu files in here to add your weapon to the weaponmenus.

18. I’m not going to cover weapon files and scriptmenus. The only thing I haven’t covered yet is the worldmodel. I ‘d like to refer you to a tutorial made by the great modder, MCh2207Cz, who’s been telling me how to import a weapon in cod2 and helping me with other things! 
This is the worldmodel tutorial: http://callofduty.filefront.com/file/Modeling_tutorial_Part_2;99649
This is a pack of additional files you’ll need: http://callofduty.filefront.com/file/Modelling_tutorial_Part_3;114881


I hope to see alot of awesome custom weapons in the game soon!

Every credit goes to MCh2207Cz for telling me how to do this and helping me with problems that occurred!

Thx & Regards,
Masterbott // JesseJoydb
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